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Abstract 

 
The purpose of this report is to describe the implementation of a computer vision guided line following 

robot. The robots were utilized in the contests in 2013 and 2014 with students of Thai-Nichi institute of 
Technology and Nagaoka National College of Technology students in a student overseas dispatch training 
to Thailand. The robot reads the line on the course from the camera of mobile phone.  The mobile phone 
installed Android will be applied to capture video, run the line following by communication via Bluetooth 
to the robot base. An Arduino microcontroller will speed drive the robot with PWM (Pulse Width 
Modulation) technology. An Android phone traces the line by control method. In this report, we describe 
the algorithms of the line trace which are included the PID (Proportional Integral Derivative) algorithm, 
the PID algorithm calculates the motor speeds such that the robot moves in a smooth fashion around line 
course, and how to the robot and the development environments of Arduino and Android on the PC.   
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１．はじめに 
 
近年，国際競争が激化し生産拠点を海外に移転す

る企業が年々増加している．上場企業の 7割が海外
生産を実施するなど，ものづくりの現場の多くは海

外へと移転している．エンジニアには技術力以外に，

英語力や国際化が求められている．将来のエンジニ

ア育成を目指す長岡工業高等専門学校（以下，長岡

高専と略す）においても，学生を海外に派遣し，現

地学生と国際交流を行う学生海外派遣研修の取組み

が行われている．その一つとして，2013 年からタ
イ日工業大学と長岡高専とで交互にコンテストを開

催している．コンテストは 8月下旬から 9月に，タ
イにおいて開催される Android Following Line Robot 
(以後 AFRと記す)と，5月に長岡高専で開催される
Gr-SAKURA LED Music and Dance (以後 GLMDと記
す)である．日本とタイの学生とで混合チームを作
り，設定課題について共同で作品を制作し，他チー

ムとレースや作品のパフォーマンスを競い合う．

GLMDコンテストは 2014年に，AFRコンテストは 



 

 

 
図-1 ライントレースロボットの構成図 

 

 

図-2 AFRで使用するハードウェア 

 

 

図-3 AFR用シールド配線パターン 

 

 

図-4 AFRシールド回路図 

 

2013年と 2014年とで既に 2回開催されている１）２）．

本論文においては，AFR コンテストで用いたライ
ントレースロボットの開発方法と動作アルゴリズム

の解説および検討を行った． 
 

 

２．ハードウェア構成 
 
ライントレースロボットの構成を図-1 に示す．

ロボットは，携帯端末からの操縦指示を Bluetooth
通信によりモータ制御用マイコン(Arduino Uno)に送
信する．マイコンには Bluetooth 通信モジュールが
搭載されており，受信した信号に応じたモータ制御

を行う．ロボットには左右のモータがついており，

PWM 信号によりモータ回転数が制御され走行する．  
全ハードウェアは日本やタイはもちろん多くの国で

入手可能である．AFR コンテストでは，事前に各
国で部品を入手し作成したロボットを持込んだ．各

チームはマシンやプログラムの調整，コースのテス

ト走行に多くの時間を費やすことができた．図-2

に主なハードウェアの写真を示す． 
 
２．１ 携帯端末 
 ライントレースロボットでは背面カメラを装備し

Android が搭載されている携帯端末を用いる．携帯
端末として KYOCERA 社製 DIGNO ISW11（図-2 

①）を使用した．Android OSは Ver.2.3.5である． 
 
２．２ Arduino Unoマイコンボード 
 Arduino は安価で簡単に使用できるように 2005
年にイタリアで開発された組込みボードである．基

板上に AtmelAVRマイコンが搭載され，5Vで駆動
する．Arduinoの統合開発環境を持つ PC より，ク
ロスプラットフォームで開発でき USB 接続でプロ
グラムをダウンロードすることでスタンドアローン

動作が可能である．Arduino Uno (ATmega328) マ
イコンボード (図-2②) を使用した． 
 
２．３ Arduino プロトシールド 

 プロトシールドは Arduino Unoの上に設置し，機
能拡張用の電子回路を作成する基板である．本論文

では，電子回路の安定性を高めるため，プリント回

路パターン基板を起こした（図-2③）．図-3 に配

線パターンと図-4 に作成したプロトシールド外観

写真を示す．図-4において左は Arduinoである．図
右は作成したシールドで，Arduino の上にピンコネ
クタ端子をもちいて設置可能である．基板上には

Bluetoothモジュールや H-Bridgeの他に LEDやコン
デンサ，抵抗，プッシュスイッチが配置される．図

-5 に AFR用シールド回路図を示す．基板を起こすこ

とは時間と費用が掛かるため，数が少ない場合は市

販されている SparkFun 製プロトシールドキット
(SFE-DEV-0914)（図-2④）を購入し，キットの 
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図-5 AFRシールド回路図 

 

 

図-6 AFRシールド回路概念図 

 

 
図-7 Bluetoothモジュール 

 

 
図-8 Hブリッジ IC SN754410ピンアサイン 

 

ユニバーサルエリアに電子回路を作成する方法が良

い．図-6 に AFR シールド回路の概念図を示す．
Bluetooth モジュール用に通信端子 (BT-RX, BT-TX) 
と 電 源 +5V, GND ， H-Bridge 用 に +5V, GND, 

MoterA+,  A-，B+, B-そして SW，LED の各端子に
合計 12箇所の接続を行う． 

 

２．４ Bluetoothモジュール 

 携帯端末との通信にはデジタル機器用近距離無線

通信の「Bluetooth」を利用する．これは，携帯端末
や周辺機器等がケーブルを使わずに，ワイヤレスで

接続され機器間で音声やデータをやりとり可能とす

るものである．Bluetooth モジュールは，図-7 に示

す sparkfun社の BlueSMiRF WRL-12582を使用した． 

 
２．５ H-Bridge 
 モータに駆動 IC にはテキサス・インメンツ社製
H ブリッジ IC SN7544103)を使用した．図-8 に

SN754410 ピンアサインを示す．左右のモータは，
図-7 中の 3-6pin と 11-13pin に接続を行う．モータ
制御には 2-7pinと 10-15pinを用いる． 
 

２．６ ツインモータギアーボックス 

 モータのギアボックスには，TAMIYA 社製
TWIN-MOTOR GEARBOX を使用した（図-2⑤）．

2 つのモータのパワーを別々に伝えられ，組立て式
であり，ギア比として標準 (58:1) と低速 (203:1) を
選択できる．本論文では低速 (203:1) を利用した． 
 

２．７ 車体部品 

 車体部品には，TAMIYA 社製ユニバーサルプレ
ートセット（図 -2⑥）と，タイヤ部品には

TAMIYA 社スリムタイヤセット（図-2⑦）を使用

した． 
 
 
３．Androidアプリケーション開発環境 
 
 ライントレースロボットは携帯端末上で動作する

Android アプリケーション（以後 Android アプリと
記す）によって制御されている．Android アプリを
開発するためには PC 上に開発環境を構築すること
が必要である．Android アプリは JAVA 言語で開発
することができ，そのプログラム開発には 1）JDK 
(Java Development Kit) ， 2） eclipse， 3）Android 
SDKを PC上にインストールする必要がある． 
 

３．1 JDKのインストール 

 JDKは，Java言語を使ってプログラムを記述し，
動作させる為に必要なソフトウェアのセットであり，

オラクル社サイトからダウンロード可能である． 
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図-9 eclipseの pluginインストール 

 

 
図-10 新しい Repositoryを Locationに追加 

 

 
図-11 Pluginを直接指定する方法 

 

 
図-12 Android SDK Managerの起動 

 
http://www.oracle.com/technetwork/java/javase/downloa
ds/index.html．最新版 Java SE 8u20 (2014/10/3 現在) 
の JDK を選択し，Linux 版や Windows 版，そして
64bit 用(x64) と 32bit 用(x86) から使用している PC
環境に最適なものを選択しダウンロードする．ダウ

ン ロ ー ド を 行 う 為 に は ， 「  Accept License 
Agreement」にチェックを入れライセンスに承諾す
る必要がある．本論文では Win版 64bitをダウンロ
ードし，完了後にインストール作業を行った． 
 

３．２ eclipseのインストール 

 Eclipse は 統 合 開 発 環 境  (IDE: Integrated 
Development Environment) と呼ばれる java開発ツー
ルである．アンドロイド開発サイト http:// 
developer.android.com/sdk/index.html より「Download 
Eclipse ADT」をクリックし，注意書きを読み「□ I 
have read and agree with the above terms and conditions」
にチェックを入れ， adt-bundle-windows-x86_64-
20140702.zip をダウンロードする．ファイル名の最
後「20140702」は開発バージョンを示す．拡張子の
「.zip」は圧縮ファイルであることを示す．アーカ
イブソフトを使って展開すると，展開先フォルダ中

に実行ファイル eclipse.exeが作成される． 
 
３．３ eclipseの ADT pluginのインストール 

 3.2 節でインストールした eclipse.exe を起動し，
plugin のインストールを行う．メニューバーより 
[Help] → [Install New Software] を選択する（図-9) ． 
インストールウィンドウ上の Work with:に新しい
Repository を追加する為，「Add」ボタンをクリッ
クし「https://dl-ssl.google.com/android/eclipse/」をロ
ケーションに追加する（図-10）． 
 「Developer Tools」にチェックを入れ「Next」ボタ
ンを押す．ダウンロードされるツールの一覧の表示

画面で「Next」ボタンを押す．ライセンスを読みチ
ェックを入れ「Finish」ボタンを押す．これにより
pluginソフトウェアのインストールが開始される． 
 プロクシーを使ったネットワークで行う場合は，

ADT-plugin ファイルを先にダウンロードしておき，
eclipse に登録する方法もある．その場合，
https://dl.google.com/android/ADT-23.0.4.zip を任意の
フォルダに保存し eclipse より[Help]→[Install New 
Software]を選択する（図-9）．インストールウィン

ドウ上の Work with:に新しいファイルを追加する為，
「Add」ボタンをクリックし「Archive」ボタンを押
し保存場所の ADT-23.0.4.zip を指定する（図-11）． 
 

３．４ Androidバージョンにあわせた APIのイン
ストール 

 携帯端末によって，稼動している Android OS の
バージョンが異なる．アプリ開発のターゲットとな

る携帯端末 OSバージョンを調べ必要な APIをイン
ストールする必要がある．携帯端末 OS バージョン
は，携帯端末上で「設定」→「端末情報」→
「Android バージョン」で知ることができる．次に
Eclipse のメニューバーより  [Window] → [Android 
SDK Manager] を選択する (図-12) ．  
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図-13 プロクシー設定 

 

 
図-14 APIの選択 

 

 
図-15 APIのライセンス承諾 

 

 
図-16 LineTrackerプロジェクトのインポート 

 

 
図-17 Propertiesの選択 

 

 SDK Managerを用いて APIをダウンロードする為
には，学内プロクシー設定が必要となる．Android 
SDK Manager のメニューバーより  [Tools] → 
[Options] を選択し設定を行う（図-13）．次に OS
バージョンに合った API をチェックする（図-14）．

チェックした API毎にライセンス承諾が必要となる．
各々Packages ウインドウで選択し「Accept License」
をクリックする（図-15）． 
 
 
４．ソフトウェア構成 
  

ライントレースロボットには 2つのソフトウェア
コンポーネントが必要である．Android アプリであ
る LineTracker コンポーネンツと Arduino のプログ
ラムである Amarinoコンポーネンツである． 
 

４．１ LineTrackerの登録 

 LineTracker は PID 制御をモータのスピードを制
御する Android アプリである．下記サイトより
http://www.scs.ryerson.ca/mfiala/robotics_club/robot_pr
ojects/Radu_android_robot/LineTracker.zip ダウンロー
ドし任意の場所に保存しておく．次に eclipse より
LineTracker プロジェクトのインポートを行う．メ
ニューバーより [File] → [Import…] → [General]→ 
[Existing Projects into Workspace]→[Next]と操作する．
Select archive file:にて [Browse...]をクリックし
LineTracker.zipを選び Finishを押す（図-16）． 
 インポートされた LineTracker には Arduino との
通信で必要となる Amarinoライブラリが抜けている，
サ イ ト https://amarino.googlecode.com/files よ り 

AmarinoLibrary_v0_55.jarをダウンロードする．次に，
プロジェクトに Amarino ライブラリを追加する．
Package Explorerで LineTrackerを選択，メニューバ
ーより [Project] → [Properties] を選択する（図-17）． 
Properties 画面の左枠より  [Java Build Path] → 
[Libraries タブ ] → [AmarinoLibrary.jar] を選択し 
[Edit…] をクリックし AmarinoLibrary_v0_5.5.jar を
選択する (図-18) ．ビルドする OS のターゲットを
設定する．  [Project]→[Properties]→画面の左枠
[Android]とし，ビルドターゲットを選択する．本論
文では[Android 2.3.3]とした（図-19）． 
 eclipse では，PC 上に仮想の携帯端末（以後，仮
想端末と呼ぶ）を作成し仮想端末上で Android アプ
リの動作確認が可能である．メニューバーより 
[Window] →  [Android Virtual Devices Manager] → 
[Create] → [AVD Name] を選択し，仮想端末に任意
の名前を入れる．本論文では DIGNO とした． 
[Device: Nexus S (4.0”, 480x800: hdpi)] → [Target: 
Android 2.3.2-API Level 10] → [CPU/ABI: armeabi] → 
[Skin: No skin] とし仮想端末を作成する（図-20）． 
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４．２ 仮想端末での動作確認 

 プロジェクトをビルドし，仮想端末上で動作確認

を 行 う ． メ ニ ュ ー バ ー よ り [Run]→[Run 
Configurations…]→左画面より [Android Application]
を選択しダブルクリック又は，New ボタンより
[New Configuration]を作成する．Name: に識別名を
記入し， [Android] タグより Project: に LineTracker
を選択， [Target] タグより「DIGNO」を選択し 
[Run] を押す（図-21）．初期状態では，LineTracker
の Android アプリは起動と同時に停止する．これは， 

 

 
図-18 AmarinoLibrary_v0_5.5.jarの追加 

 

 
図-19ビルドターゲットの選択 

  

 
図-20 仮想端末の作成 

  

 

図-21 Run Configurations画面 

仮想端末上で Bluetooth デバイス等の外部装置の動
作を再現できず，通信エラーが発生する為である．

仮想端末上で実行する場合は，通信処理部分のコメ

ントアウトが必要である．Project Exproler より 
[LineTracker] → [src] → [line.tracker] → [lineTracker. 
java]のコードを表示し，21 行目の Amarino.connect
関数をコメントアウト（//を行頭に記入）する（図-

22）．図-23 に仮想端末上で LineTracker を起動し
た時の動作画面を示す． 
 
４．３ LineTrackerの構成 

 LineTracker は以下に示す①から④の 4 つの java
ファイルから構成されており，各ファイルにはクラ

スのメンバーが定義されている．各ファイルと含ま

れるクラスおよびメソッドを以下に示す． 
①LineTracker.java 

•public class LineTracker extends Activity implements 

SensorEventListener 

•protected void onCreate(Bundle savedInstanceState) 

•protected void onStop() 

•public void onAccuracyChanged(Sensor arg0, int arg1) 

•public void onSensorChanged(SensorEvent event) 

②ArduinoReceiver.java 

•public class ArduinoReceiver extends BroadcastReceiver 

•public void onReceive(Context context, Intent intent) 

③Preview.java 

 

 

図-22 Amarino. Connect関数のコメントアウト 

 

 
図-23 仮想端末上での LineTracker動作画面 
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•public class Preview extends SurfaceView implements 

SurfaceHolder.Callback 

–Preview(Context context, DrawOnTop drawOnTop) 

•public void surfaceCreated(SurfaceHolder holder) 

•public void onPreviewFrame(byte[] data, Camera camera) 

•public void surfaceDestroyed(SurfaceHolder holder) 

•public void surfaceChanged(SurfaceHolder holder, int format, 

int w, int h) 

④DrawOnTop.java 

•public class DrawOnTop extends View 

•public DrawOnTop(Context context) 

•protected void onDraw(Canvas canvas) 

•public int findTape(int[] rgb, int width, int height) 

•public void grayscaleToBlackWhite(int[] rgb, byte[] yuv420sp, 

int width, int height) 

 LineTrackerクラスは，Bluetoothデバイスの MAC
アドレス取得・通信を行い，ライントレースアルゴ

リズムを呼び出す主幹となるクラスである．図-24

に LineTracker クラスのダイアグラムを示す．
Preview クラスはカメラの開始や携帯端末の画面の
大きさを扱うクラスである．図-25 に Preview クラ
スのダイアグラムを示す．  
 

 
図-24 LineTrackerクラスのダイアグラム 

  

 
図-25 Previewクラスのダイアグラム 

 DrawOnTop クラスには，カメライメージを解析
し，床に張られた黒テープ（以後，テープと呼ぶ）

の位置を判定する FindTapeCenterメソッド．および，
テープの中心と携帯画面の中心との差を計算し，

PID 制御によりモータへの回転指令を出すライント
レースアルゴリズムが含まれるクラスである．図-

26 に DrawOnTop クラスのダイアグラムを示す． 

FindTapeCenter メソッドは，白と黒に二値化された
カメライメージより，テープの中心を見つけ出す．

図-27 に FindTapeCenter の流れ図を示し，以下に処
理手順について述べる． 
1）カメライメージ画像を ImageWidth方向に 50ピ
クセルおきに pix走査する． 
2）pix走査: ImageHeight方向の黒色素子を探す． 
3）ImageHeight方向に minPixels以上黒色の素子が
連続した場合はテープ発見とする． 
4）テープ発見とならなかった場合は ImageWidth方
向に 50ピクセルずれ pix走査を繰返す．テープを
発見した場合は，ビット演算処理を行い発見された

テープを緑色表示する． 
 

 

図-26 DrawOnTopクラスのダイアグラム 

    
 図-27 FindTapeCenterのフローチャート 
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図-28 FindTapeCenterメソッド 

 
図-28に画面の走査方法とソースコードを示す． 
 
４．４ 携帯端末での動作確認 

 携帯端末において Android アプリを実行するため
には，パソコンと携帯端末とをつなぐ USB ケーブ
ル，および PC 側に携帯端末のドライバソフトがイ
ンストールされている必要がある．ドライバソフト

は機種毎に異なる為，製造メーカのサイトよりダウ

ンロードしインストールが必要である．機種によっ

ては USB 接続ドライバの他，ABD(Android Debug 
Bridge)ドライバが必要な場合がある．また，携帯端 

 
図-29 ターゲットデバイスの設定 

 

 

図-30 携帯端末で LineTrackerの起動 

 

末設定で開発者モードへの変更が必要となる．携帯

端末にて，[設定]→[アプリケーション]にて[提供元
不明のアプリ]にチェックする．[設定]→[ アプリケ
ーション]→[開発]にて[デバッグモード]，[スリープ
モードにしない]と[擬似ロケーションを許可]にチェ
ックを入れる必要がある．携帯端末での実行は，メ

ニ ュ ー バ ー よ り [Run]→[Run Configurations] の
[Target]タグより，ターゲットとなるデバイスとし
て[Active devices]を選択すればよい(図-29)．図-30

に携帯端末上で LineTracker起動した様子を示す． 
 
４．5 Arduinoのソフトウェア 

Arduino は，高価なロボット制御用デバイスの代
わりとして開発されてきた．モータ制御のための

PWM 出力，汎用性の高い I/O ピンを多く持つなど，
ロボットの制御に適している．Arduino のプログラ
ミングは C 言語で書かれている．PWM 制御や

Bluetooth 通信のライブラリが提供されており，ラ
イブラリ関数を使うことでコーディングの労力を節

約できる．また，IC へのプログラムのダウンロー
ドを含む統合開発環境が用意されている．統合開発

環 境 の 導 入 に は ， Arduino の 開 発 サ イ ト
(http://arduino.cc/en/Main/Software)より Arduino IDE 
(最新版 Arduino 1.0.6 2014/09/30 現在)をダウンロー
ドする．ダウンロード終了後にインストールを行う． 
 次に，Arduino コードを下記サイトより取得する．
(http://www.scs.ryerson.ca/mfiala/robotics_club/robot_pr

50ピクセル毎に pix走査 

pix
走
査

 
テープの始まりを発見 
tmpStartに座標値を代入 
 
テープが続く限り tmpEnd に座
標値を代入 
 
テープ幅が mixPixels以上の場合
はテープ発見とする． 

黒色ピクセルかを判定 

テープ発見場所を
緑色として表示 

テープ中心位置を返す 
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図-31 MeetAndroidライブラリの追加 

 

 
 図-32 ライントレースロボット回路 

 
ojects/Radu_android_robot/arduino_control.zip) 

arduino_control.zipを解凍後， Arduino IDEを起動
しメニューバーより [File] → [Open] arduino_control
フォルダ内の [arduino_control.pde] を選択する． 

arduino_controlには Android端末との Bluetooth通
信が用いられている，MeetAndroidライブラリであ
る MeetAndroid_4.zipを下記サイトより取得する． 
http://amarino.googlecode.com/files/MeetAndroid_4.zip 
Arduino IDEのメニューバーより [Sketch] → [Import 
Library…]→[Add Library…]とし，MeetAndroid_4.zip
ファイルを選択する．これにより MeetAndroid ライ
ブラリが追加される（図-31）． 
 メニューバーの下のチェックマークのボタンを押

すことで，スケッチ（Arduino ではコードをスケッ
チと呼ぶ）のコンパイルとリンクがなされる．

Arduino ではこの処理を「Verify」と呼ぶ．また，
USBケーブルで Arudinoと PCを接続し，その隣に
ある右矢印のボタンを押すことでプログラムのダウ

ンロードを行う．Arduino ではこの処理を「Upload」
と呼ぶ．USB 接続は，PC 側でシリアル接続と認識
されそのポート番号は PC 環境によって異なるため，
メニューバーの [Tools] → [Serial Port] より適切なポ
ートを選択する必要がある． 
 Bluetooth 通信に用いる通信速度として 119200bps
を用いる．そのため，スケッチの 31 行目

Serial.begin の括弧内の数値を 57600 から 119200 へ
と書き直す必要がある．arduino_contorol では，図-

32 に示す回路図を想定しプログラムされている．

図-33は完成したロボットの写真である． 
 

 
図-33 完成したロボットの写真 

 
 

５．PID制御アルゴリズム 

 
ライントレースロボットには PID制御が用いられ

ている．PID 制御は，フィードバック制御の一種で
あり，入力値𝑢𝑢(𝑡𝑡)の制御を出力値と目標値との偏差
𝑒𝑒(𝑡𝑡)，その積分，および微分の 3 つの要素によって
行う方法であり，式 (1) で定義される． 

 

𝑢𝑢(𝑡𝑡) = 𝐾𝐾𝑝𝑝𝑒𝑒(𝑡𝑡) + 𝐾𝐾𝑖𝑖 ∫ 𝑒𝑒(𝜏𝜏)𝑑𝑑𝑑𝑑𝑡𝑡
0 + 𝐾𝐾𝑑𝑑

𝑑𝑑
𝑑𝑑𝑑𝑑 𝑒𝑒(𝑡𝑡)  (1) 

 
 PID制御を離散時間で実現する為，DrawOnTop.java
ファイル内の onDrawクラス内 (82行目以降) にコー
ドが記述されている．以下に PID制御コードの各行
を式 (2) から (6) として示す． 
 
proportional = tapeCenter - mImageHeight/2;   (2) 

 integral = integral + proportional;   (3) 

 derivative = proportional - last_proportional;  (4) 

 last_proportional = proportional;   (5) 

 int lineError = (int) (proportional * Kp + integral * Ki + 

derivative * Kd);    (6) 

 

 式(2)において，tapeCenterは FindTapeメソッドが
カメライメージよりライン認識を行ったテープ中心

位置の横座標値を示す．mImageHeight は端末画面
横幅を示し，2で割ることにより画面中心座標と  
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図‐34 proportional値の決定 

 

なる．式(2)より，比例値 proportional には画面中心
とテープ中心との差が代入される（図-34）．式(3)
は積分値 integral を決定する．integral に，前回から
の integralと現在の proportionalの変数値を加算し代
入すると積分を示す．式 (4) ， (5) は微分値 deri-
vativeを決定する．現在の差を示す proportionalと，
前回の derivativeの変数値を保持する last_ derivative
との差を derivative に代入することで微分を示す．
式 (5) において，現在の derivative の変数値を last_ 
derivativeに代入し次のループの準備をする． 
 式  (6) において，proportional ， integral，  deri-
vative の各変数に比例ゲインを示す Kp，積分ゲイ
ンを示す Ki，微分ゲインを示す Kdとの乗算を行い，
総和を求めることで出力値を算出する．出力値は

lineError に代入される．次に，lineError の変数値を
用いたモータスピードの制御アルゴリズムについて

述べる．LineError の変数値が０以下の場合は，図-

34 で示される様に携帯画面の中心より左側にテー

プのある可能性が高い．ロボットを左に回転させる

ため，左のモータを減速する．同様に lineErrorの変
数値が 0 以上の場合は，右のモータを減速する．
lineError の変数値が 0 であった場合は，ライン上を
ロボットが進んでいることを意味し，左右のモータ

スピードは最高速度の状態となる． ゲインを示す
Kp，Ki，Kp の各変数は，DrawOnTop.java ファイル
内の DrawOnTopクラス内 (32行目以降) に int型の
変数として記述されている．使い勝手の問題から倍

精度浮動少数型である double型で Kp，Ki，Kpを宣
言するよう修正を行う．各変数には初期ゲイン値と

して Kp=1，Ki＝2，Kd=0 が与えられている．PID
制御に最適なゲイン値を与える代数的な方法は存在

しないため，試行錯誤的に最適値を探すものとなる．

そこで，proportional の値に注目した状態推移手法
を含め次の 3手法を提案する． 
手法1）proportional変数の値が一定値以下であった
場合はPID制御アルゴリズムへの入力を0とする．
手法2）pix走査範囲を制限する． 
手法3）携帯解像度を低くする． 
 手法2) と手法3) は携帯端末の処理速度を向上さ
せる効果があり，提案手法の有効性については2014
年コンテストにおいて確認を行った． 
 

 

６．まとめ 
 
 携帯端末のカメラ映像を使って，コース上に書か

れたラインをトレースするライントレースロボット

を作成し，タイへの学生海外派遣研修においてタイ

日工業大学の学生との2013年および2014年のコンテ
ストに活用した．PC上にAndroidとArduinoの開発環
境の構築について解説を行い，ロボットの作成方法

と制御アルゴリズムについて解説と検討を行った．

PID制御は制御方法として一般的であり広く用いら
れている．しかし離散信号でPID制御を実現し，ゲ
インを調整しその振る舞いを経験的に理解できる機

会は少ない考えられる．本論文で作成したライトレ

ースロボットは電子工学，アルゴリズム，制御工学

の知識を深めるのに有用と考えられる． 
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